Downgrading Rubygems

By rainkinz on Jul 11, 2011, comments 10

Sadly I need to work with a rails 2.3.3 and 1.2.3 app now and then and the latest rubygems has issues with these old versions of rails. For example:

rake my:task:name
rake/rdoctask is deprecated.  Use rdoc/task instead (in RDoc 2.4.2+)
rake aborted!
uninitialized constant ActiveSupport::Dependencies::Mutex

So I have to downgrade. Not a huge deal. I'm now using rbenv

gem update --system 1.4.2
5768
Ff8987a51e1cf26c06081b4e6a01453a.png?s=48&d=http%3a%2f%2fkuripai.com%2fassets%2fguest Sanchez on Sep 11, 2015 at 6:04 AM

Thanks this was helpful. I was gitetng weird errors trying to install Mongrel until I did `sudo apt-get install ruby1.8-dev`. I also needed to apt-get install libopenssl-ruby as it is not included in the ruby install automatically in the Ubuntu world. To get a mysql client I used `apt-get install libmysql-ruby`.

5934
422fb3b52c055a5a671285183344d37b.png?s=48&d=http%3a%2f%2fkuripai.com%2fassets%2fguest Aira on Jan 06, 2016 at 7:23 PM

Real brain power on dilpasy. Thanks for that answer!

Comment: